long gap alignment

Find answers to common questions for CodonCode Aligner and the Aligner License Server

long gap alignment

Postby ssig » Mon Oct 27, 2014 5:16 pm

After adding sequences to an assembly with the preferences set to long gap alignment, oftentimes parts of the sequences are then grayed out, such that they are basically illegible. I can't figure out how to reverse this, its automatic and once it has happened removing the sequence from the assembly doesn't reverse it.
ssig
 
Posts: 1
Joined: Sat Oct 25, 2014 2:32 pm

Re: long gap alignment

Postby Peter Richterich » Tue Oct 28, 2014 9:15 am

Greyed out parts of sequences could not be aligned - they are unaligned ends. Some possible reasons why this can happen are trying to assemble sequences that are too diverse, and low-quality / high error rate sequence at the beginning and/or end of sequences.

For individual sequences, you can use the "Mark start alignment" and "Mark end alignment" menu items (check the Aligner Help for more details). But note that this will not add any require gaps, so the formerly greyed out parts will still be misaligned.

To reduce unaligned ends, here are some things to try:
- end clip sequences before assembly
- change the scoring in the preferences, for example by reducing penalties
- make sure to use the most current version of CodonCode Aligner.
Peter Richterich
Site Admin
 
Posts: 85
Joined: Thu Aug 21, 2008 7:23 pm


Return to Support & Questions



Who is online

Users browsing this forum: No registered users and 1 guest

cron